远程登陆提示 发生身份验证错误,要求的函数不受支持

今天新开的服务器,Win7竟然远程不上,提示:远程登陆提示 发生身份验证错误,要求的函数不受支持。如下图显示:

 

用Win10的系统,远程可以正常登陆,排除服务器的问题。度娘以下,发现是因为 新开的服务器安装了CVE-2018-0886的更新。

没有Win7对应的补丁文件,可以通过修改组策略解决。

首先要打开组策略: 开始菜单 > 运行 > 输入 gpedit.msc。

打开组策略时:依此点击 计算机配置 > 管理模板 > 凭证分配 > 加密 Oracle 修改,双击打开。

选择已启用 > 然后保护级别选择: 易受攻击。点击确定即可。

网上还有一种修改注册表的方法,没有进行测试,一起贴出:

  1. 登录实例或者本地计算机。
  2. 单击 开始 > 运行,输入 regedit,单击 确定
  3. 定位到 HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters 键。如果 CredSSP 或者 Parameters 键不存在,请新建 CredSSP 或者 Parameters 键。
  4. 在 Parameters 键下新建 DWORD 值 AllowEncryptionOracle,并设置数据为 2

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注

This site uses Akismet to reduce spam. Learn how your comment data is processed.